Jump to content

Welcome to Nissan GT-R Heritage
Register now to gain access to all of our features. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more. If you already have an account, login here - otherwise create an account for free today!
Photo

Help with Airbag Code

- - - - -

  • Please log in to reply
13 replies to this topic

#1
LuvSpeed

LuvSpeed

    Stock

  • Member
  • Pip
  • 33 posts
  • Joined 15-May 16
  • LocationColorado

Hello all,

 

I hope that somebody can help me.  I had my radio stop working and my nav start acting weird on my 2009 GTR.  I purchased and recently installed the upgraded nav system from legertas.  Everything seems to be working with the system after the install.  However, I am getting a passenger airbag code that I can not clear.  I have tried to clear the code by using the ignition switch method as described in online videos.  I also have tried to clear the code using my COBB tuner.  The code is b1023.  Passenger airbag off indicator circuit is opened or shortened.  

 

Legertas has been very responsive to my questions.  He stated that the airbag control unit is between that rear seats and the sensor is located in the passenger seat.

 

Any ideas on where to start?  I'm not good with electrical stuff. One question that I have:  Could it be related to any of the connections I made behind the dash?  I'm willing to take things back apart, but would like to know what to look at.  There is a passenger airbag light by the SD card slot

 

I appreciate any help.

 


'17 Huracan, pretty much stock
'09 GTR
'14 Viper TA#3

#2
7racer

7racer

    Stage 4 Member

  • OEM Member
  • 7,721 posts
  • Joined 24-March 13
Doing the radio install should have any effect for n the airbags.

Do you have aftermarket seats?

In7anity!!


#3
LuvSpeed

LuvSpeed

    Stock

  • Member
  • Pip
  • 33 posts
  • Joined 15-May 16
  • LocationColorado

I do not have aftermarket seats. I did not remove the seats during the install either.  The instructions given by Legertas show how to clear the airbag code, so I think this thing must happen during the radio install.  


'17 Huracan, pretty much stock
'09 GTR
'14 Viper TA#3

#4
7racer

7racer

    Stage 4 Member

  • OEM Member
  • 7,721 posts
  • Joined 24-March 13

I do not have aftermarket seats. I did not remove the seats during the install either.  The instructions given by Legertas show how to clear the airbag code, so I think this thing must happen during the radio install.  

 

 

hmm it just doesn't make sense.  Could you look under the seat, its a white connector, just make sure its plugged in

this is the POS to defeat it, but the thread should give you a location of where to look

http://www.gtrherita...360#entry127804


In7anity!!


#5
LuvSpeed

LuvSpeed

    Stock

  • Member
  • Pip
  • 33 posts
  • Joined 15-May 16
  • LocationColorado

just looked at the seat connections.  will order the pos.  thx for your help .


'17 Huracan, pretty much stock
'09 GTR
'14 Viper TA#3

#6
shawnhayes

shawnhayes

    Stage 4 Member

  • OEM Member
  • 5,083 posts
  • Joined 11-September 13

Very likely that if this happened during the install, you pulled one of the wires.  What did you do with the faceplate on the old nav?  I believe it has a connection to the SRS system some way.  

 

Shawn


  • 7racer likes this

#7
shawnhayes

shawnhayes

    Stage 4 Member

  • OEM Member
  • 5,083 posts
  • Joined 11-September 13

brand_rr-carbon-fiber-gt-r-shift-knob-bl

 

See that little light in the faceplate?  Hooks to the SRS system.  Check THAT connector.

 

Shawn


  • 7racer likes this

#8
7racer

7racer

    Stage 4 Member

  • OEM Member
  • 7,721 posts
  • Joined 24-March 13

just looked at the seat connections.  will order the pos.  thx for your help .

 

don't order the POS!!!  I think Shawn has the right idea


In7anity!!


#9
7racer

7racer

    Stage 4 Member

  • OEM Member
  • 7,721 posts
  • Joined 24-March 13

nice knob Shawn! lol


  • shawnhayes and droptopp like this

In7anity!!


#10
shawnhayes

shawnhayes

    Stage 4 Member

  • OEM Member
  • 5,083 posts
  • Joined 11-September 13

nice knob Shawn! lol

 

Not my knob my friend.  Too lazy to go to the garage, I just pulled an online image.  But I know the SRS light in the little faceplate hooks to the SRS system, and certainly could be affected by a legertas install.

 

Shawn



#11
LuvSpeed

LuvSpeed

    Stock

  • Member
  • Pip
  • 33 posts
  • Joined 15-May 16
  • LocationColorado
Ok thanks for the input. Will check that connection. Won’t have time until this weekend. Will give an update.
'17 Huracan, pretty much stock
'09 GTR
'14 Viper TA#3

#12
legertas

legertas

    Stage 1 Member

  • Vendors
  • 111 posts
  • Joined 13-October 14
  • LocationLithuania

OEM way to check to AIRBAG codes without any equipment . 

Attached Images

  • gtr srs1.jpg
  • gtr srs2.jpg
  • gtr srs3.jpg

  • 7racer likes this
16509003 1822982454610305 6579302092427434087 N

 Nissan GTR R35 CBA entertainment and navi upgrade to OEM DBA "HD" MFD

 

CBA clusters conversion to DBA NISMO

 

 
LBP 3693
Album: legertas
18 images
0 comments


 

 


#13
LuvSpeed

LuvSpeed

    Stock

  • Member
  • Pip
  • 33 posts
  • Joined 15-May 16
  • LocationColorado
Took everything back apart. Checked all the wires from the electrical circuit behind the light in the face plate. Indeed there was a small little connector that I did not attach. This took care of the problem. If anybody else has this problem, recheck all the electrical connections coming from the airbag light by the S.D. card slot!
  • 7racer likes this
'17 Huracan, pretty much stock
'09 GTR
'14 Viper TA#3

#14
shawnhayes

shawnhayes

    Stage 4 Member

  • OEM Member
  • 5,083 posts
  • Joined 11-September 13

Took everything back apart. Checked all the wires from the electrical circuit behind the light in the face plate. Indeed there was a small little connector that I did not attach. This took care of the problem. If anybody else has this problem, recheck all the electrical connections coming from the airbag light by the S.D. card slot!

 

YAY!

 

Glad I helped somebody today.

 

Shawn


  • 7racer and LuvSpeed like this




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users